After SLES 10.3 -> SLES 11.1 upgrade, I cannot login

I currently have a Virtual Machine that is running a SLES 10 SP3 Server.
After upgrading from this to SLES 11 SP1 (I selected the option to only
update the existing files that were installed), I find that I am not
able to login to the operating system as root or any system user. In
order for me to actually login, I had to run Rescue Mode and change the
passwords for root and the other system users using passwd before I was
able to login. I have never seen this happen before. After taking a
quick look through this forum, and using google, I have not really seen
anyone else mentioning having this issue.

So, I wanted to see if any other users may have encountered something
like this? If not, are the any useful suggestions of where I might be
able to look for clues as to what happened–other than /var/log/warn and

Thanks for any help!


jbabicka’s Profile:
View this thread:


It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

  • Visit and search the knowledgebase and/or check all
    the other self support options and support programs available.
  • You could also try posting your message again. Make sure it is posted in the
    correct newsgroup. (

Be sure to read the forum FAQ about what to expect in the way of responses:

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team

I have this same issue. It is not a Virtual Machine. I upgraded from SLES 10 SP4 to SLES 11 SP1. I was able to boot to a rescue disk, chroot, and change passwords. However, this means all passwords will have to be changed. This is ok for a Sandbox system, but it will not work with a Production system.

Could it have something to do with the PAM modules, or the the hash in the shadow file?

Any help would be appreciated.


Hi regs995,

there are other reports as well - lastest one I’ve been involve can be found here:

While no resolution has been reported in that thread, maybe Mike (“endc01”) is willing to provide feedback on how his case got solved?

Please also note that there’s no direct migration path SLES10SP3 to SLES11 ( - probably some required change was introduced with SLES10SP4. As far as I recall the default encryption mechanism was “blowfish” with SLES10, but later (SP4?) changed to “md5” - do you still have access to the old /etc/default/passwd file to compare?

With regards,

we had a similar problem!

i solved this by removing the following line


commented this for SLES11SP1 out ( BUG because doesn’t exists )

#session required


Hi all.

After upgrading other servers, I discovered the problem went away after the updates were applied. The old passwords in the shadow file then worked.

Thanks for the responses.

Hi regs995,

thank you for sharing that information!