Canal switching to ipv6

hello !
I created a cluster using the openstack provider and node templates, the cluster bootstrapped fine with no problems.
then i manually added cloud_provider in the cluster options to use cinder for storage, that caused canal to switch to ipv6 which broke container logging and shell ( error 1006 )
any idea why this is happening?
using the same cloud_provider config on a cluster created using existing nodes doesn’t cause this problem.
im using k8s 1.17.4 and HA rancher 2.3.5

i tried setting

echo 1 > /proc/sys/net/ipv6/conf/default/disable_ipv6
echo 1 > /proc/sys/net/ipv6/conf/all/disable_ipv6

but im still getting ipv6 pod ip