Can't use Japanese keyboard after installation


I found my Japanese keyboard didn’t work correctly.
When I install, my Japanese keybard works correctly. But when I log in my Pi3, I found my Japanese keybaord’s keymap is not detectly correctly.
xdm.erros shows below
Kernel command line: BOOT_IMAGE=/Image-4.4.21-81-default root=UUID=0b2c007e-1581-42e2-a05c-4a66eb4c115d root=/dev/disk/by-id/mmc-00000_0x65da5528-part3 disk=/dev/disk/by-id/mmc-00000_0x65da5528 resume=/dev/disk/by-id/mmc-00000_0x65da5528-part4 loglevel=3 plymouth.enable=0 console=ttyS0,115200n8 console=tty quiet
Build Date: 14 October 2016 08:06:04PM

Current version of pixman: 0.34.0
Before reporting problems, check
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Thu Jan 1 09:00:36 1970
(==) Using config directory: “/etc/X11/xorg.conf.d”
(==) Using system config directory “/usr/share/X11/xorg.conf.d”
The XKEYBOARD keymap compiler (xkbcomp) reports:

Error: No Symbols named “basic” in the include file “jp”
Abandoning symbols file “default”
Errors from xkbcomp are not fatal to the X server
xdm info (pid 1183): sourcing /etc/X11/xdm/Xsetup
xdm info (pid 1183): sourcing /etc/X11/xdm/Xstartup
xdm info (pid 1329): executing session /etc/X11/xdm/Xsession

Is this related some packages?




It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

Be sure to read the forum FAQ about what to expect in the way of responses:

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot…

Good luck!

Your SUSE Forums Team