Convoy-nfs causing containers to fail with File Not Found error

So I have been using convoy NFS for a while. For whatever reason today when I try to restart several of my services I get the following error, it almost looks like something is awry with the path that convoy thinks the docker service on the local host should be using. If I check the path it does not exist.

Error (404 Client Error: Not Found (“open /var/lib/rancher/convoy/ops01ss0001-e1-94a721ac-a210-4f0a-bfa2-3b22a8399fc3/mnt/jenkins-analytics: no such file or directory”))

To resolve this I have tried tearing down the services and rebuilding but I still get the same error. However if I create a new service I am able to map to convoy-nfs storage volumes just fine.

I event went as far as deleting the entire convoy-nfs service and redeploying it. I also changed the name of the stack and services which didn’t seem to solve it either.

Anyone have any ideas what I could do to troubleshoot this further?

1 Like

I have a workaround, but it certainly isn’t ideal.

  1. Upgrade the storage pool link to a local volume.
  2. Accept upgrade as complete, once finished.
  3. Upgrade again back to the intended storage pool.
  4. Accept upgrade as complete, once finished.
1 Like

More discussion on a similar topic is going on at: