Errors after changing registration IP, and back


Another possible connectivity problem? I have changed the registration IP to that of a load balancer (AWS), but reverted to the elastic IP of the rancher again.
Now, on my hosts I can no longer see the CPU, Memory etc. information. I cannot get to any logs and cannot start a console.

There’s nothing in the ranger-agent logs. On the rancher master i see:

time="2015-10-02T13:50:14Z" level=error msg="Error during upgrade: [websocket: could not find connection header with token 'upgrade']" 
2015/10/02 13:50:14 http: multiple response.WriteHeader calls

When trying to view logs, and a pair of the multiple response.WriteHeader calls when viewing a host.

I did try to remove the agent on a host and re-register it to no avail. Adding a new host works, but it suffers from the same issue.

So… did I change anything else? Possibly, as I’ve tried all I could think of to make this work…

Where should I look?

Hmm. Updating to v40 solved it…

I’m glad updating helped, but for future reference, we did add some more detailed troubleshooting items. Like how to check that host registration is setup okay.

The documentation lists this:

sudo docker run -d -e CATTLE_AGENT_IP=<HOST_IP> --privileged \ -v /var/run/docker.sock:/var/run/docker.sock \ rancher/agent:v0.8.2 http://SERVER_IP:8080/v1/scripts/xxxx

However, I am trying to figure out what to put for xxxx since I didnt save the original registration url.

Is there a place I can retrieve it?

If you click on “Add Host”, under the “Custom” option, it always shows what the docker run command would be to launch rancher/agent.