fglrxinfo returns an error

Hi all,

I was trying to run matlab on my SLED 11 SP1 and when I run a
particular m-file / script, the matlab crashes and I get an error in the
terminal that I used to run the Matlab.

MATLAB: xcb_io.c:352: _XReply: Assertion `!dpy->xcb->reply_data’
Aborted (core dumped)

I searched for a solution on the internet, and I found out that this is
a problem with ATI drivers … so I tried, fglrxinfo … and I got the
following result …

fglrxinfo: xcb_io.c:352: _XReply: Assertion `!dpy->xcb->reply_data’
Aborted (core dumped)

someone mentioned that there is a workaround to this, that is through> sax2 -r -m 0=fglrx after doing a > sax2 --initial … This seemed to fix the problem for the original poster BUT for me
it escalated the problem, as neither did the original error go away and
NOW the touchpad stopped working …

I tried setting the things in sax2 BUT … anytime I tried to Save
settings, I kept getting parse error on line 75: There must be
identifier here
… and if I try Test the sax2 settings, then
sometimes I get to a blue screen from which no escape key or even
CTRL+ALT+BACKSPACE gets me back, except reboot and sometimes I get a
blank screen, and again the only option is reboot …

So I tried to check out the Synaptic Touchpad settings, BUT there was
no touchpad being detected there !!! and I didn’t know what to do …

So, tried to check out the ATI Control Center … BUT upon trying to
run the ATI Control Center from the Control Center in SLED … I get no
response … (probably an error occuring in the background …)

so… I finally did a sax2 settings restore, getting some help from
guys on IRC … and so … now at least my trackpad is running … BUT
all the other problems remain …

-p.s. … why is my Novell icon red ? :stuck_out_tongue: it used to be yellow … and
for some other people I see it is green … so, if I keep asking
questions … it keeps going down ??? :stuck_out_tongue: … maybe i finally get kicked
off this forum? :P-


junaidnaseer’s Profile: http://forums.novell.com/member.php?userid=97333
View this thread: http://forums.novell.com/showthread.php?t=446878


It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

  • Visit http://support.novell.com and search the knowledgebase and/or check all
    the other self support options and support programs available.
  • You could also try posting your message again. Make sure it is posted in the
    correct newsgroup. (http://forums.novell.com)

Be sure to read the forum FAQ about what to expect in the way of responses:

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team

Nobody replied / knew on this forum … anyways, Somebody on another
forum was really helpful and gave the following answer to my problems,
which actually did solve my problem.

2011-11-07 18:17:44 changed by mbadalic ¶

Hi again!

Today I have found a final solution to this problem! A have noticed
that after upgrading the kernel also some other programs stopped
working, but with a different error output (when I started them from the
terminal). On one forum I have found some info, that the problematic
thing was the video driver of the graphic card (ATI) and that the
solution was to first delete “x11-video-fglrxG02” and
“ati-fglrxG02-kmp-desktop” packets, reboot the system, reinstall the two
packets again and reboot the system. After doing this all the
problematic programs started working normally and also the problematic
vbox machines (with 3D enabled) started to work normally!


2011-11-09 08:34:34 changed by junaidnaseer ¶


Thank you very much. That really did solve all the problems.
running inside the SuSE Linux with 2D and 3D support enabled …

Thank you again.

p.s. I found out … ‘Novell Forums FAQ’
(http://forums.novell.com/faq.php?faq=novfor#faq_rankicons) and

all apologies … anyways, can someone tell me how to delete my old
posts on this forum … or how to delete my account and start all over
again … I have posted too many crazy frustrated posts here … :frowning:


junaidnaseer’s Profile: http://forums.novell.com/member.php?userid=97333
View this thread: http://forums.novell.com/showthread.php?t=446878