Not able to extend root partition


I need to increase the space in my root or volume. I have edited the VM with the added space, and when I look at the fdisk on the SLES server, I see the added space on the drive. Now I want to extend the partition. I tried the many ways of doing this and ran the command “resize2fs /dev/sda3,” but it did not resize. I got the message “The filesystem is already 15202560 blocks long. Nothing to do.”

I have pasted few command outputs below; please help me, I am feeling stuck here,

Also, in this system, there is no volume group created.

Disk /dev/sda: 214.7 GB, 214748364800 bytes
255 heads, 63 sectors/track, 26108 cylinders, total 419430400 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes
I/O size (minimum/optimal): 512 bytes
Disk identifier: 0x00077708

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 417791 207872 83 Linux
/dev/sda2 417792 8818687 4200448 82 Linux swap / Solaris
/dev/sda3 8818688 62894078 27037695+ 83 Linux
/dev/sda4 62894080 83886079 10496000 83 Linux

Number Start End Size Type File system Flags
1 1049kB 214MB 213MB primary ext3 boot, type=83
2 214MB 4515MB 4301MB primary linux-swap(v1) type=82
3 4515MB 32.2GB 27.7GB primary ext3 type=83
4 32.2GB 42.9GB 10.7GB primary ext3 type=83

Filesystem Size Used Avail Use% Mounted on
/dev/sda3 26G 24G 175M 100% /
udev 7.9G 96K 7.9G 1% /dev
tmpfs 7.9G 0 7.9G 0% /dev/shm
/dev/sda1 197M 55M 132M 30% /boot
/dev/sda4 9.9G 618M 8.8G 7% /var
/dev/sr0 1.4G 1.4G 0 100% /media/dac6000

PRETTY_NAME=“SUSE Linux Enterprise Server 11 SP4”

Anyone Can help here ?

From what you’ve written it sounds like you increased the size of the virtual disk but haven’t changed anything via fdisk? Given your fdisk output you wouldn’t be able to increase the size of /dev/sda3 without first doing something with /dev/sda4.

No using this fdisk nothing worked, Tried so many but I have used GPARTED ISO which has solved problem

1 Like