SUSE Cloud 5 - Error in Crowbar webinterface

Hi everyone,

I have another question about the cloud, especially the crowbar webinterface.
When I want to list my active roles in the dashboard, I get an error saying:

We're sorry, but something went wrong Please consult your log files or double check the URL you're trying to reach. If this is an application error, we encourage you to visit the SUSE support site for more information. Return to the dashboard.
The output of production.log provides:

I, [2015-05-27T10:43:22.339245 #9636] INFO -- : Completed 500 Internal Server Error in 493ms F, [2015-05-27T10:43:22.341222 #9636] FATAL -- : ActionView::Template::Error (undefined method `[]' for nil:NilClass): 9: .panel.panel-default 10: .panel-heading 11: %h2 12: = display_name_for(barclamp) 13: .panel-body 14: - { |role| { :role => role, :elements => role.element_nodes(@roles, @nodes) } }.each do |locals| 15: - unless locals[:elements].empty? lib/barclamp_catalog.rb:67:in `display_name' lib/barclamp_catalog.rb:35:in `method_missing' app/helpers/barclamps_helper.rb:52:in `display_name_for' app/views/dashboard/active_roles.html.haml:12:in `block in _app_views_dashboard_active_roles_html_haml__807530730056444146_40051540' app/views/dashboard/active_roles.html.haml:8:in `each' app/views/dashboard/active_roles.html.haml:8:in `_app_views_dashboard_active_roles_html_haml__807530730056444146_40051540'

I have seen the roles before, so this is something that came up after our successful installation, and we didn’t have any major changes.
What I tried was to restart rcapache2 and rccrowbar, no effect. All our nodes have been restarted multiple times since the installation due to updates and patches, but still the same error.

Our setup consists of three nodes, admin and control node are Xen VMs running on SLES11-SP3, compute node is a physical machine running SLES12. We use almost all default settings, the cloud itself is working fine. We are able to upload images and run instances. As the crowbar webinterface is running on admin node, I assume the cause is somewhere on the admin node.

Is anyone able to help or at least has other ideas where to look for hints? That would be great!



It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

Be sure to read the forum FAQ about what to expect in the way of responses:

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team

This could happen if one barclamp is not listed in /opt/dell/crowbar_framework/config/catalog.yml. Could you double-check if all barclamps that are supposedly used are there? Also, it might be good to file a service request with a supportconfig of the admin server, so that this can be looked at more closely.