Touchpad settings change upon reboot


I have a small problem. Everytime I reboot, the touchpad / trackpad
stops working. Not even at the login screen nor afterwards either.

Then, when, I look into the Synaptics Device Settings (navigating with
the keyboard, of course), I find that the device has been set as
“Pointing Stick”.

When, I “Reset Devices”, from the Synaptics Device Settings, it starts
showing the “Standard Pointing Device” instead of the “Pointing Stick.”

I logout, the touchpad starts working again. And I can login and do my

UNTIL, I reboot the system again. When I have to go through the whole
routine again.

Any suggestions please?

p.s. if I boot in failsafe mode, this problem doesn’t occur.


junaidnaseer’s Profile:
View this thread:

p.s. I checked into the /etc/X11/xorg.conf.Synaptics-inc and
the/var/log/Xorg.0.log files …

I found nothing wrong. You see the files here.

‘[Bash] junaid naseer suse synaptics -

thanks …


junaidnaseer’s Profile:
View this thread:

Ok … so I am not sure, BUT I think, I escalated the problem. I have
lost the file xorg.conf.Synaptics-inc and now i can’t right click and
whole lot of other things … any help would be appreciated … :slight_smile:


junaidnaseer’s Profile:
View this thread:

OK … so in order to fix my first problem … that is the touchpad was
being detected as a pointing stick upon reboot …

I uninstalled synaptic drivers … and rebooted … and things went
from bad to worse …

I don’t know what happened BUT X server stopped running … gdm kept
giving errors …

so, I booted into my backup OS … and looked for some help on the
internet … things looked bleak at that point … I was contemplating,
a complete re-install …

but I found out that maybe my xorg.conf is corrupted now …

I removed all the old "xorg.conf"s and rebooted but still X would not
start … I tried invoking startx and gdm but no result …

I tried with xdm and walaaah … it worked … I managed to log in to
gnome … and got a new xorg.conf through Xorg :1 -configure …

I reinstalled the synaptics drivers from the sled repositories …
basic functionality was returned … BUT …

but like I said in my last post … the synaptic features did not
return even with the synaptic drivers re-install …

so … well half an hour ago … I was looking for a solution again on
the internet and found out the synaptic gesture suite from my laptop
manufacturer for SLED …

I installed that … and

now everything is back to normal …

maybe it helps someone … so I posted this … :slight_smile:

good luck and good night …


junaidnaseer’s Profile:
View this thread:

oh hell … the problem is back again … i guess there is some problem
with the synaptic gesture suite … it keeps setting my touchpad to
pointing stick upon reboot … oh well … time to stand by system
always from now on … :stuck_out_tongue:


junaidnaseer’s Profile:
View this thread:

I have faced the same issue on several laptops several times and already
posted in the forum how to resolve it. Yes, it was the complete package
It looks this (posting how-to’s here) is the only way to help others to
solve their problems if there is a solution. I’ve tried to contact
developers several times but it didn’t help at all.
Once I found a bug and even suggested a solution. It was Ekiga which
failed to show video. The problem was in ptlib package which was
configured without v4l2 option. Of course I could configure and compile
it myself and had Ekiga working as it should to. But the answer from
support team puzzled me so much that I simply couldn’t find proper words
to reply to it. There was something like this:[color=blue]

We fully support Skype, and Ekiga was not part of the package. Could you
please confirm ?
Did you try with Skype ? I can escalate the issue but I want to be sure
it is Ekiga-related defect only[/color]


AlexDudko’s Profile:
View this thread:

Me too. However, I did not revert to this option, still having the touchpad disabled, operating with the mouse.

On the contrary, I have none of these, but the problem persist.

Now, before upgrading to SP2, I have come back to the problem. Again googled and tried various advices, including Novell document 3067387

  • but no success.
    The only thing I am sure of is the touchpad hardware is OK, as it works in another tested Linux distro.

I took notice that during my first updating after purchase of HP Compaq with SLED 11 SP1 preinstalled changes occured in xorg.conf and xorg.conf.Synaptics-inc. Now I am trying to find the original files which made the touchpad working.

Where is it posible to find the operational, original conf files? Or at least their proper sections, “InputDevice”, etc.
Attempts to use xorg.conf.orig for this purpose have failed, as they date to the first connection to Novell repositories.

Thanks in advance

Another day, another advice.

I have manage to solve the issue owing to the change of synaptics-touchpad package from HP, described by AlexDudko:

Thanks, Alex!

[QUOTE=LLiner;2974]Another day, another advice.

I have manage to solve the issue owing to the change of synaptics-touchpad package from HP, described by AlexDudko:

Thanks, Alex![/QUOTE]

Nice to here it helped!