udev rules are not reflecting changes without reboot

Created SLES 12 SP2 ISO with SuSE Studio.
Installed the ISO with 70-persistent-net.rules file in /etc/udev/rules.d with custom names for PCI devices.
Then tried to reload the udev rules with command “udevadm control --reload-rules” followed by “udevadm trigger”.

But still in ifconfig the network interfaces have default names and not picked from rules file. This was working in SLES 11 SP4.
Tried putting file in /usr/lib/udev/rules.d, which also did not work. Removed the rules file from /usr/lib/udev/rules.d.

Now rebooted the system. Network interfaces now have the custom names defined in /etc/udev/rules.d/70-persistent-net.rules file. But IP address were not assigned although the ifcfg-* files are in /etc/sysconfig/network.
Did a “systemctl restart network” and it worked.

Is there a way to reload the udev rules without rebooting the system in SLES 12 SP2?

Manpreet Singh


It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

Be sure to read the forum FAQ about what to expect in the way of responses:

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot…

Good luck!

Your SUSE Forums Team