VNC remote access not displaying "@", "<", ">" characters

I’ve searched and searched for a solution to this problem, but am getting nowhere. Perhaps someone here can help?
I have a few SLES 11 SP2 servers running in VMware VMs. Access to them works fine from VMware vSphere console access, as does SSH terminal access, but my problem occurs when trying to use VNC access. For this I’ve tried to use TightVNC and UltraVNC clients on a Windows 7 desktop.

The problem is that certain characters are not being interpreted by either of the VNC clients, or the VNC server configuration. The characters that I have found don’t work are “@”, “<” and “>”, but I suspect that there may be more.

I have tried a few suggestions that I found, around adding “-xkb” to the VNC server config file in /etc/xinetd.d or changing keyboard-related settings but these do not seem to work for me.

Anyone else come across this problem? Any help with a solution much appreciated, thanks.


It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

Be sure to read the forum FAQ about what to expect in the way of responses:

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team

Hi ashbrook.
I had the same problem and on my kit it was an issue with the keyboard mapping ( SLES installed with United Kingdom keyboard ).

Using TightVNC viewer ( client ) connect to your SLES Box and change the keyboard layout to USA. The keyboard layout option is at the bottom of the window ( TightVNC 2.7.7 ).

The keys you mentioned then started working for me.

Hope this helps,