Worker node waiting to register in Vagrant/Virtualbox

#1

Hi, although there is an existing/extensive vagrant stack (https://github.com/rancher/vagrant) I wanted to work through things from the ground up to gain deeper understanding (as I did with Rancher v1) and as such have been trying to create my own vagrant deployment.
It has gone more or less ok and I’m close, however I can’t seem to get a worker node to register.
I’m using vagrant private networking for all instances and leaving docker IPs to be auto allocated. I’m advised I could use --address 'IP' in the docker run command, but aren’t sure which IP to use there? I’ve tried using IPs from the same range as the virtualbox private network range but that makes things worse and nothing hooks up.
Any advice or pointers would be most appreciated and I will be happy to share my vagrant stack once (if) I can get it to fully deploy.

waiting-to-register

#2

To update on this I tried switching to a public network config (the LAN) as oppose to private networking, however the worker node registration issue remains the same.
I’m guessing I maybe don’t know enough about vagrant networking for docker containers on vbox guests, but would appreciate any pointers if port forwarding is the area I should be looking at (although I did think that vagrant boxes on a private network could communicate with each other).

#3

A further update, I’ve since tried an absolute advised version of Docker (1.13.1), but I’m still seemingly unable to get the node to register.

I know I’m obviously missing something basic due to my lack of knowledge of Vagrant, Docker and Rancher, but no idea what, and it is confusing that the server node (running etcd + controlplane) drops in ok, yet the worker node (running worker) just sits there in a waiting to register state.

#4

Probably hitting https://github.com/rancher/rancher/issues/11365

1 Like
#5

Many thanks @superseb, yes, that certainly looks like it.

I’m not sure which IP I would use though? I did try using an IP matched to the virtualbox private subnet (thus allocating to the container) but that made everything worse and nothing connected at all.

Wondering if I use 10.0.2.15 (as per my screen grabs) if it would work?

#6

To update, using the specified IP 10.0.2.15 doesn’t work. The worker node still just sits waiting to register.

I’m unsure where to go with this next.

#7

I’m getting similar results on aws, worker node waiting to register.

2 Likes
#8

Having the same issue is anyone found a way to overcome it?