x11vnc can't find MIT-MAGIC-COOKIE

When I run x11vnc from ssh as the user that’s controlling the local X11
session, I get


03/01/2012 13:59:59 x11vnc version: 0.9.4 lastmod: 2008-09-16
No protocol specified

03/01/2012 13:59:59 ***************************************
03/01/2012 13:59:59 *** XOpenDisplay failed (:0.0)

*** x11vnc was unable to open the X DISPLAY: “:0.0”, it cannot continue.
*** There may be “Xlib:” error messages above with details about the failure.

Some tips and guidelines:

and the message continues telling me to use -auth, -findauth, etc. If I
sit down at the local session, it starts fine.

Running -echo $XAUTHORITY- in the local session tells me my XAUTHORITY
file is “/var/run/gdm/auth-for-bobpaul-mZ1BwR/database”. Running -x11vnc
-auth /var/run/gdm/auth-for-username-mZ1BwR/database -display :0.0-
results in the same error above. Additionally, xdpyinfo doesn’t work


bobpaul@lonepine:~>env XAUTHORITY=/var/run/gdm/auth-for-bobpaul-mZ1BwR/database xdpyinfo -display :0
No protocol specified
xdpyinfo: unable to open display “:0”.

The file is definitely owned by the user:


-rw------- 1 bobpaul bobpaul 54 2011-12-26 10:29 /var/run/gdm/auth-for-simetkos-mZ1BwR/database

My understanding was if ssh’d using the same user (bobpaul) that’s
controlling the local session AND provided the path to the
MIT-MAGIC-COOKIE file, that really nothing else could go wrong.

It’s SLES 11, 64bit

bobpaul@lonepine:~>lsb_release -a
LSB Version: core-2.0-noarch:core-3.2-noarch:core-4.0-noarch:core-2.0-x86_64:core-3.2-x86_64:core-4.0-x86_64:desktop-4.0-amd64:desktop-4.0-noarch:graphics-2.0-amd64:graphics-2.0-noarch:graphics-3.2-amd64:graphics-3.2-noarch:graphics-4.0-amd64:graphics-4.0-noarch
Distributor ID: SUSE LINUX
Description: SUSE Linux Enterprise Server 11 (x86_64)
Release: 11
Codename: n/a


bobpaul’s Profile: http://forums.novell.com/member.php?userid=116723
View this thread: http://forums.novell.com/showthread.php?t=450224


It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

  • Visit http://support.novell.com and search the knowledgebase and/or check all
    the other self support options and support programs available.
  • You could also try posting your message again. Make sure it is posted in the
    correct newsgroup. (http://forums.novell.com)

Be sure to read the forum FAQ about what to expect in the way of responses:

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team