Add signed SSL cert to Rancher server

I re-deployed my Rancher server (2.2.5-rc15) using a signed SSL certificate and my previously managed clusters are now listed as Unavailable. What’s the best way to re-attach these clusters?

Here is the docker run command:
docker run -d --restart=unless-stopped
–name rancher-server
-p 80:80 -p 443:443
-v /data/rancher/var/lib/rancher:/var/lib/rancher
-v /data/certs/cert.pem:/etc/rancher/ssl/cert.pem
-v /data/certs/key.pem:/etc/rancher/ssl/key.pem
rancher/rancher:v2.2.5-rc15 --no-cacerts

Did you solve this ?
I also have this issue when I change the certificates I loose my clusters.

Sorry, I don’t we ever solved this when hit this last year.

@Kingsbro_Superfly You should probably repost your question as a new question since a lot has changed since 2.2. Make sure you include the command that you ran, as well as the output and any errors. Please check the container logs and include any relevant information here.

Note that some operations require the files to be strictly named tls.crt and tls.key, and using a name like cert.pem will fail because the name doesn’t match what’s expected inside the container. I don’t know if that’s the case here, but it did cause problems for me recently (But I run Rancher on top of Kubernetes, not directly from Docker).