Can’t access rancher UI

Sorry for the NOOB question.

I have just installed Rancher on my server but cannot access it VIA my browser

sudo docker run -d --restart=unless-stopped -p 8080:8080 rancher/server

I can access it locall

curl http://127.0.0.1:8080/v1
{“id”:“v1”,“type”:“apiVersion”,“links”:{“accounts”:“http://127.0.0.1:8080/v1/accounts",“agents”:“http://127.0.0.1:8080/v1/agents”,“apiKeys”:“http://127.0.0.1:8080/v1/apikeys”,“auditLogs”:“http://127.0.0.1:8080/v1/auditlogs”,“azureadconfigs”:“http://127.0.0.1:8080/v1/azureadconfigs”,“backupTargets”:“http://127.0.0.1:8080/v1/backuptargets”,“backups”:“http://127.0.0.1:8080/v1/backups”,“certificates”:“http://127.0.0.1:8080/v1/certificates”,“composeProjects”:“http://127.0.0.1:8080/v1/composeprojects”,“composeServices”:“http://127.0.0.1:8080/v1/composeservices”,“configItemStatuses”:“http://127.0.0.1:8080/v1/configitemstatuses”,“configItems”:“http://127.0.0.1:8080/v1/configitems”,“containerEvents”:“http://127.0.0.1:8080/v1/containerevents”,“containers”:“http://127.0.0.1:8080/v1/containers”,“credentials”:“http://127.0.0.1:8080/v1/credentials”,“databasechangeloglocks”:“http://127.0.0.1:8080/v1/databasechangeloglocks”,“databasechangelogs”:“http://127.0.0.1:8080/v1/databasechangelogs”,“dnsServices”:“http://127.0.0.1:8080/v1/dnsservices”,“environments”:“http://127.0.0.1:8080/v1/environments”,“extensionPoints”:“http://127.0.0.1:8080/v1/extensionpoints”,“externalDnsEvents”:“http://127.0.0.1:8080/v1/externaldnsevents”,“externalEvents”:“http://127.0.0.1:8080/v1/externalevents”,“externalHandlerExternalHandlerProcessMaps”:“http://127.0.0.1:8080/v1/externalhandlerexternalhandlerprocessmaps”,“externalHandlerProcesses”:“http://127.0.0.1:8080/v1/externalhandlerprocesses”,“externalHandlers”:“http://127.0.0.1:8080/v1/externalhandlers”,“externalHostEvents”:“http://127.0.0.1:8080/v1/externalhostevents”,“externalServiceEvents”:“http://127.0.0.1:8080/v1/externalserviceevents”,“externalServices”:“http://127.0.0.1:8080/v1/externalservices”,“externalStoragePoolEvents”:“http://127.0.0.1:8080/v1/externalstoragepoolevents”,“externalVolumeEvents”:“http://127.0.0.1:8080/v1/externalvolumeevents”,“githubconfigs”:“http://127.0.0.1:8080/v1/githubconfigs”,“haConfigInputs”:“http://127.0.0.1:8080/v1/haconfiginputs”,“haConfigs”:“http://127.0.0.1:8080/v1/haconfigs”,“healthcheckInstanceHostMaps”:“http://127.0.0.1:8080/v1/healthcheckinstancehostmaps”,“hostApiProxyTokens”:“http://127.0.0.1:8080/v1/hostapiproxytokens”,“hosts”:“http://127.0.0.1:8080/v1/hosts”,“identities”:“http://127.0.0.1:8080/v1/identities”,“images”:“http://127.0.0.1:8080/v1/images”,“instanceLinks”:“http://127.0.0.1:8080/v1/instancelinks”,“instances”:“http://127.0.0.1:8080/v1/instances”,“ipAddresses”:“http://127.0.0.1:8080/v1/ipaddresses”,“kubernetesServices”:“http://127.0.0.1:8080/v1/kubernetesservices”,“kubernetesStacks”:“http://127.0.0.1:8080/v1/kubernetesstacks”,“labels”:“http://127.0.0.1:8080/v1/labels”,“ldapconfigs”:“http://127.0.0.1:8080/v1/ldapconfigs”,“loadBalancerServices”:“http://127.0.0.1:8080/v1/loadbalancerservices”,“localAuthConfigs”:“http://127.0.0.1:8080/v1/localauthconfigs”,“machineDrivers”:“http://127.0.0.1:8080/v1/machinedrivers”,“machines”:“http://127.0.0.1:8080/v1/machines”,“mounts”:“http://127.0.0.1:8080/v1/mounts”,“networks”:“http://127.0.0.1:8080/v1/networks”,“openldapconfigs”:“http://127.0.0.1:8080/v1/openldapconfigs”,“passwords”:“http://127.0.0.1:8080/v1/passwords”,“physicalHosts”:“http://127.0.0.1:8080/v1/physicalhosts”,“ports”:“http://127.0.0.1:8080/v1/ports”,“processDefinitions”:“http://127.0.0.1:8080/v1/processdefinitions”,“processExecutions”:“http://127.0.0.1:8080/v1/processexecutions”,“processInstances”:“http://127.0.0.1:8080/v1/processinstances”,“projectMembers”:“http://127.0.0.1:8080/v1/projectmembers”,“projects”:“http://127.0.0.1:8080/v1/projects”,“pullTasks”:“http://127.0.0.1:8080/v1/pulltasks”,“register”:“http://127.0.0.1:8080/v1/register”,“registrationTokens”:“http://127.0.0.1:8080/v1/registrationtokens”,“registries”:“http://127.0.0.1:8080/v1/registries”,“registryCredentials”:“http://127.0.0.1:8080/v1/registrycredentials”,“resourceDefinitions”:“http://127.0.0.1:8080/v1/resourcedefinitions”,“schemas”:“http://127.0.0.1:8080/v1/schemas”,“self”:“http://127.0.0.1:8080/v1”,“serviceConsumeMaps”:“http://127.0.0.1:8080/v1/serviceconsumemaps”,“serviceEvents”:“http://127.0.0.1:8080/v1/serviceevents”,“serviceExposeMaps”:“http://127.0.0.1:8080/v1/serviceexposemaps”,“serviceProxies”:“http://127.0.0.1:8080/v1/serviceproxies”,“services”:“http://127.0.0.1:8080/v1/services”,“settings”:“http://127.0.0.1:8080/v1/settings”,“snapshots”:“http://127.0.0.1:8080/v1/snapshots”,“storagePools”:“http://127.0.0.1:8080/v1/storagepools”,“taskInstances”:“http://127.0.0.1:8080/v1/taskinstances”,“tasks”:“http://127.0.0.1:8080/v1/tasks”,“typeDocumentations”:“http://127.0.0.1:8080/v1/typedocumentations”,“userPreferences”:“http://127.0.0.1:8080/v1/userpreferences”,“virtualMachines”:“http://127.0.0.1:8080/v1/virtualmachines”,“volumes”:“http://127.0.0.1:8080/v1/volumes”},“actions”:{},“baseType”:"apiVersion”}

Is it because the port is only open on tcp6 and not 4?

Proto Recv-Q Send-Q Local Address Foreign Address State User Inode PID/Program name
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 0 11036 445/sshd
tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN 0 67650 14685/nginx: master
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 0 67648 14685/nginx: master
tcp6 0 0 :::22 :::* LISTEN 0 11038 445/sshd
tcp6 0 0 :::80 :::* LISTEN 0 67649 14685/nginx: master
tcp6 0 0 :::8080 :::* LISTEN 0 58860 13406/docker-proxy

ps -aux | grep 8080
root 13406 0.0 0.0 117636 2664 ? Sl 10:41 0:00 /usr/bin/docker-proxy -proto tcp -host-ip 0.0.0.0 -host-port 8080 -container-ip 172.17.0.2 -container-port 8080

1 Like