Cannot get mouse to work

I am trying out the new SLES15 and have migrated a vm from SLES11SP4. SLES15 looks much better than SLES12 as I am not getting any system slow downs or hanging when using the KVM hypervisor. However, in graphics mode, the keyboard works fine, but I cannot get the mouse to function at all. I have the graphics tablet option installed and have tried the VNC and Spice graphics but I get the same result in that the mouse disappears when over the virtual machine and reappears when over the normal desktop.

I have tried numerous combinations of the settings duplicating those on the SLES11 server (Cirrus graphics) but no luck as of yet.

Anyone got any ideas as the new SLES15 implementation looks very good and I would like to get on further with the testing. AT the moment, the networking is not working for the vm, but I will look into this once I get the mouse back.

Many thanks


It looks like I need to install the spice-vdagent on the migrated vm. However, SUSE do not have a working one for SLES11, only SLES12 and 15. I have tried using the VNC connection and CIRRUS graphics but cannot get the mouse to work in this case. I also tried to install versions 16 and 17 of the vdagent, but got failed dependencies in each case so it looks like it will be text displays for SLES11 vm’s unless I can get the vnc and CIRRUS display to work with the mouse support.



I have now been testing the KVM implementation for a couple of days and find that it works extremely well compared with SLES12 and is having no effect upon the server performance (AMD 8 core) running the kvm package. Very pleased with the result, only problem is that I still cannot get the mouse to work in the Display VNC configuration, but have found a strategy to combat this.

When you import a vm from an earlier version, the import routine sets up the video as QXL and Display as Spice. ALso, it looks like the network has problems. The procedure is as follows:
Boot the vm, and it will default to text mode (does not like the graphics setting). Run the text version of YAST and reconfigure the vm network card (no problems here). Also make sure that you have VNC set up in YAST as well. Make sure that you can ping the vm. Shut the vm down now and make changes to the display to VNC and the Video to Cirrus if you want to try to get the mouse to work, otherwise make no changes to the video and display. Reboot the vm, and it will come up again under text mode as before. However, if you VNC in from another computer, you will then have the graphical interface you require, with everything working as expected.

Just need backup exec to get sorted now.