Cattle-cluster-agent ERROR when importing cluster

Hello, I recently created a raspberry pi cluster (4 raspberry pis with 8gb ram), and sat up a kubernetes cluster for them with a K3S backend. They’re running the 64 bit version of the raspberry pi os, k3s version 1.18.8+k3s1 and kubernetes 1.18.8. Whenever i try to import this on my rancher v2.4.8 server, the cluster gets stuck on “pending”. After further investigating I found this error
ERROR: https://[my hostname].com/ping is not accessible (Could not resolve host: [my hostname].com)
Right above this, it also mentions the resolv.conf, which doesn’t contain my nameserver.

On Github I found this issue which seems to be the exact same problem.
They mention a workaround of setting dnsPolicy from ClusterFirst to dnsPolicy: Default, and i was wondering how i’d do that. I’ve also tried opening a shell inside the pod, but it would auto restart before i could change /etc/resolv.conf.

See the response here