certificate signed by unknown authority

Hi. I am using latest version of Rancher and i am getting this error ("2019-07-26 10:51:25.518141 I | embed: rejected connection from “” (error “tls: failed to verify client’s certificate: x509: certificate signed by unknown authority (possibly because of “crypto/rsa: verification error” while trying to verify candidate authority certificate “kube-ca”)”, ServerName “”), while setting up the Master (by choosing Node option as etcd and control panel)

Could use a little more context here. Is this an error on an HA Rancher cluster or a cluster being created by Rancher? How is this cluster being created? i.e. Which workflow?

Ok so i have created one cluster, by selection Node option as ectd and control panel, from Rancher web GUI. and this Cluster in being created in different VM.
And i am getting this error on newly created cluster.

Sorry was away last week on vacation. Is this error on the screen? Is the cluster being created and not working? Add a few screen shots if you can. There lots of areas where you can get a certificate error legitimately.

Thanks for you response.But now problem has been sorted out.

hi @kamlesh, may I know how you solved the problem? I experiencing the same issue.

Ok so, this problem was because of worker node . so i cleaned everything from worker Node machine.
Again i tried to add the node into the master node. I will suggest kindly add etcd and controlplane node first then add worker node.