Change proxy setting in Environment

I’ve a running Rancher v1, needs it proxy settings to change for environment. Under cloud-config.yml its looked as,

rancher:
environment:
HTTPS_PROXY: httx://proxy.example.com:8080
HTTP_PROXY: httx://proxy.example.com:8080
NO_PROXY: example.corp,localhost,127.0.0.1,172.16.0.0/12
http_proxy: httx://proxy.example.com:8080
https_proxy: httx://proxy.example.com:8080
no_proxy: example.corp,localhost,127.0.0.1,172.16.0.0/12

and the proxy settings need to change. I’ve tried by using the

  • sudo ros config set rancher.environment.http_proxy
    command, but restart reset to old value.
    Any idea how to do this?