Changing default Cilium CNI version in RKE2 v1.27.10

Hello, we would like to install RKE2 v1.27.10+rke2r1 Control Plane cluster with CILIUM CNI.

We don’t want to use “packed” version of cilium - v 1.14.4 , but instead we would like to use 1.15.1 which is already in rancher/rke2-charts repository.

What we need to do to define it in /var/lib/rancher/rke2/server/manifests/ ?

This is possible, though instead of overriding /var/lib/rancher/rke2/server/manifests/rke2-cilium.yaml you might want this as an add-on manifest.

Our RKE2 clusters are all deployed using Rancher+Terraform as a rancher2_cluster_v2 resource so we inject the manifest using the rke_config.additional_manifest. In RKE2 this comes thru here: /var/lib/rancher/rke2/server/manifests/rancher/addons.yaml

Below is a snippet showing where we had to set the image tags in a few spots. Cilium helm reference may also be of some help.

I would caution you as we recently ran into a case where the image tag wouldn’t override during a situation in which a new node so the cluster somehow reverted back to 1.14.1 and no defaults overridden resulting in a broken CNI.

Non-related to your image tag situation, Rancher UI does seem to show a way to supply additional configuration for Cilium though this doesn’t seem to be directly exposed outside of the UI.

kind: HelmChartConfig
  name: rke2-cilium
  namespace: kube-system
  valuesContent: |-
      tag: "v1.15.0"
        tag: "v1.15.0"
        enabled: true
          tag: "v1.15.0"