Cluster works but Rancher reports it unavailable

Upgrading Rancher from 2.5 to 2.6, I accidentally tried to upgrade to 2.6.7 which doesn’t support the Kubernetes version we’re using (1.18). The cluster-agent rollout failed and the cluster became unavailable with the error “Timeout waiting rollout agent daemonset: exit status 1, Waiting for daemon set “cattle-node-agent” rollout to finish: 1 out of 3 new pods have been updated… error: timed out waiting for the condition”.

I rolled back to 2.6.6, and manually updated the cattle-node-agent daemonset to use version 2.6.6, and managed to get the cluster back online. Everything seems to work, I can browse the cluster in the Rancher UI and I can even open a “kubectl shell” inside Rancher cluster manager and query the cluster.

BUT, Rancher is still reporting the cluster as unavailable, with the same error above. How can I reset this so it sees the cluster as available?

Have you solved the problem?

Yes I eventually managed to get the cluster working again, although I couldn’t tell you exactly what the problem actually was.