Custom ISO launching System Service

I’m trying to build a custom iso that launches one of the build in system services that is included by default (open-vm-tools specifically).

I tried adding this to os-config.tpl.yml under the service section:

  open-vm-tools:
      image: rancher/os-openvmtools:v0.8.0-rc1
      command: /usr/bin/vmtoolsd
      privileged: true
      labels:
        io.rancher.os.scope: system
      restart: always
      pid: host
      ipc: host
      net: host
      uts: host
      volumes_from:
      - command-volumes
      - system-volumes

I can build the iso and the it launches the service, but there seem to be permissions issues…

What I would actually need is to build an iso that starts with open-vm-tools enabled, basically running:

sudo ros service enable open-vm-tools

on boot.

How could this be achieved? I can’t find any documentation on the subject. Here https://docs.rancher.com/os/configuration/custom-rancheros-iso/ I found how to build the iso, and this works, but launching the service seems to be the problem.

What kind of permission issues do you run into?

Hi Josh,

thanks for your answer.
I actually solved the issue with the permissions: see more here:

But I have run in to an other issue, could you maybe land me a hand? It is in the thread mention above.

I kind of solved it, if someone is interested you can find it here:

This is more like a proof of concept and works now only on docker-machine and vsphere and needs at least 2512 MB RAM…

Are there plans to make something like this possible in a more general way?

Making it easier to build custom ISOs and other build artifacts is certainly on the roadmap.

The large memory usage is mainly due to having to use Ubuntu as a base image for open-vm-tools. https://github.com/rancher/os/issues/1487 should help with this.