Disk and User quotas for ext4 on sles11 sp3

Disk and User quota support on SLES11 for ext4

I am trying to use this information BUT for ext4. Are disk and user quota supported for ext4 ?

Works fine for ext3

:~ # cat /etc/fstab
/dev/sda1 swap swap defaults 0 0
/dev/sda2 / ext3 acl,user_xattr 1 1
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/sdb /disk ext4 defaults,usrquota,grpquota 0 0
#/dev/sdb /disk ext3 defaults,usrquota,grpquota 0 0

:confused: # quotacheck -avug
quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option.
:confused: # mount
/dev/sda2 on / type ext3 (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,mode=1777)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
securityfs on /sys/kernel/security type securityfs (rw)
gvfs-fuse-daemon on /root/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev)
/dev/sr0 on /media/SLES-11-SP3-DVD-x86_6407031 type iso9660 (ro,nosuid,nodev,uid=0)
/dev/sdb on /disk type ext4 (rw,usrquota,grpquota)
prmb-vnas-vm-dhcp005:/ #

/var/log/messages say the volume is mounted with the right options

kernel: [ 4145.325491] EXT4-fs (sdb): mounted filesystem with ordered data mode. Opts: (null)
kernel: [ 4146.612971] EXT4-fs (sdb): allowing unsupported read-write mount.
kernel: [ 4146.613097] EXT4-fs (sdb): re-mounted. Opts: usrquota,grpquota
kernel: [ 4301.354679] EXT4-fs (sdb): allowing unsupported read-write mount.
kernel: [ 4301.524914] EXT4-fs (sdb): mounted filesystem with ordered data mode. Opts: (null)
kernel: [ 4309.423287] EXT4-fs (sdb): allowing unsupported read-write mount.
kernel: [ 4309.423418] EXT4-fs (sdb): re-mounted. Opts: usrquota,grpquota

Did you create the quota files with the -c option first?

Did you manually add, I suggest using YaST and the partitioning tool to format and add quota support in the edit option of fstab.


I do not see ext4 option while using the yast disk partitioner.

Assuming no data on this?

/dev/sdb on /disk type ext4 (rw,usrquota,grpquota)

You need to use the partitioner to delete sdb (which is incorrect) and
create a new partition (which will be sdb1), format as ext4, then on
the right side of the dialog box, select the mount radio button,
add /disk in the entry area there, then click on the fstab button, in
here look at the list of check boxes and select the quota one.

Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-17-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!