Expected state running but got error "Error response from daemon Get https://registry-1.docker.io/v2/ dial tcp lookup registry-1.docker.io

I am running rancher container on localhost

docker run -d --restart=unless-stopped -p 8080:8080 rancher/server:stable

Spawned a docker node with docker machine

docker-machine create -d virtualbox rancher-server

Joined the node to rancher successfully, but cannot run any service with any container image:

Expected state running but got error: Error response from daemon: Get https://registry-1.docker.io/v2/: dial tcp: lookup registry-1.docker.io on [::1]:53: read udp [::1]:57950->[::1]:53: read: connection refused

I have run the same thing before without issue.
I must have done something globally wrong.

Any hint?

I solved this issue by removing the IP from the node public IP when adding a host to Rancher, which is supposed to be unique & public.

Still doesn’t get the relationship with the message and the docker registry mentioned with DNS ports.