Failed to find nic

Managing several hosts over several DigitalOcean droplet is working fine. But everytime I try to add one of my own hosts, I get into trouble. It stucks always while setting up containers. Rancher Server brings the following error.

2015-08-27 13:09:57,217 ERROR [ad74edaa-5237-4979-9551-b25081b5da29:55] [networkServiceProviderInstanceMap:1] [networkserviceproviderinstancemap.activate->(AgentInstanceApplyItems)] [] [cutorService-16] [i.c.p.a.i.p.AgentInstanceApplyItems ] Failed to find nic for [networkServiceProviderInstanceMap:1]

No Idea where to start. Switching off the firewall didn’t solve the problem. Running rancher-server and rancher-agent on my own hosts causes the same error. Can you help?

By the way I’ve started rancher server with this settings:
sudo docker run
–name rancher-server
-p 8080:8080
-v /home/rancher/db:/var/lib/mysqli

SOLVED myself: Suppose it was the IPv4 hardening of the hosting provider.

Let us know if you need any more help. Glad that you were able to resolve it.

Well. I thought I solved it. Got the error back later. Got one cryptic java error after the other. After spending 4 days on trying different settings, configurations and machines, I gave up. It would help to have some more hints about what prerequisites and which network/firewall settings should be there. Maybe an step-by-step idiot’s guide on Ubuntu might help. Tried it on a blank bare metal server with Ubuntu and also CoreOS. RancherOS I was not able to install, because I cannot provide an ISO image to my server at my provider. Tried it also with a big Synology NAS Server, but there it was even worse. 500/udp and 4500/udp were always opened and had ipv4 port forwarding. I tried to compare with the DigitalOcean settings, but I couldn’t figure out what was wrong.