Health checks not initializing properly?


#21

@leodotcloud I can do you one better. Here’s an exact outline of the steps required to reproduce my problem. All performed on VMware Workstation 12.5.4 running on Windows 10 x64. There is also a Windows Server 2012 R2 domain controller and DNS server running to serve my domain.

Set up 3 VMs, doing the following process on each.
Each has 4GB RAM, 2 vCPUs, 20GB single disk, bridged networking. Remove unnecessary sound card, printer, usb hardware.
Boot with CentOS-7-x86_64-Everything-1611.iso
Press enter a few times to load installer
Select english defaults
Select installation destination, accept default and click done
Click network and host name
Set hostname to ranchertest1.mydomain(others are ranchertest2 and 3)
Enable NIC
Configure NIC
Go to IPv4 settings, change method to manual
Add address 192.168.1.76 (others are 77 and 78 in order)
Netmask 255.255.255.0, gateway 192.168.1.1, DNS server to AD server, search domain to whatever the AD domain is
Save
Done
Begin Installation
Set root password
Map hostname to IP in DNS server while install completes
Click Reboot on the server when install is done
Login with root and the password previously set
Run "yum -y update"
Run "reboot"
Log in again, via SSH this time
Run "curl https://releases.rancher.com/install-docker/1.13.sh | sh"
systemctl enable docker
systemctl start docker
systemctl disable firewalld
systemctl stop firewalld
yum -y install vim
vim /etc/sysconfig/selinux
Change “enforcing” to "disabled"
reboot
SSH again when the server comes back up, as root
Now, just on ranchertest1
docker run -d --restart=unless-stopped -p 8080:8080 rancher/server
Wait for it to deploy, then hit http://ranchertest1:8080
Click "got it"
Infrastructure>hosts
Add host
Correctly identifies http://ranchertest1:8080, so leave default and click save
Historically, having Rancher auto detect the IP just ends up not working, so put in the actual IP of the server (192.168.1.77 for ranchertest2)
Copy the command
Paste into the SSH session on ranchertest2
Wait patiently, until the agent deploys and shows up in the Rancher hosts section, with all containers running
(One container, sleepy_babbage (randomly generated) shows up stopped. Not sure if intended or not.)
Click add host again
Put in 192.168.1.78 as the IP for ranchertest3
Copy and paste command into ranchertest3, run and watch the hosts page again
Everything…works…now?

Well shit, I guess this must have been fixed in a recent release after I tried previously? Leaving the process I guess, in case someone else wants a step-by-step.


#22

Thanks for the steps.


#23

+1. I am also facing the same issue. I have created 3 VM’s on Hyper-V running on Win10x64 machine. Health check keeps on failing. I tried to recreate the environment using CentOS7 on Azure and faced the same issue.