Help needed with a VPN sidecar

Hello, I’m new to Rancher so I might use the wrong terminology… I am trying to setup a VPN inside a pod and have another application use its connection. From the research I have done it looks like I need to add a sidecar to the pod to complete the task. I deployed my main pod which has an application running and I can access its UI. I then created a sidecar to that deployment for the VPN–both start up and run. If I execute a shell and run “curl” it shows a vpn ip of the region I selected.

The problem I’m having is I no longer can access the UI of the main container once the sidecar is added. I have tried moving the required ports from the main container to the vpn container with no luck. I also have tried both standard and init containers.

Any help or suggestions would be greatly appreciated.


The entire pod (“main” and “sidecar” containers) is in the same network namespace. So you vpn is likely to replace the routing for all addresses, and needs to exclude the internal IP ranges Kubernetes uses. This has nothing to do with Rancher in particular, but for our distros the defaults are and

@vincent ok thank you for the quick reply… I’ll have to continue to research…