Hosts are not connecting

I’ve got a Problem running Rancher 1.6.10 on Debian 9 with Docker 1.12.6.

When I add Hosts using a unmodified kubernetes environment. The Hosts wont expose UDP Port 500 and 4500 which results that the etcd node wont get healthy.

The Setup is 3 Hosts at the moment. 1 Host Running the Rancher Server and 2 Hosts which should be added. At this time I only can add 1 Hosts because the second one wont connect.

I allready tried to ping the ipsec container on the first host but this wont work. So I really think there is a problem with the overlay network.

I also seems that the ipsec router is stuck:

20/11/2017 11:03:04time=“2017-11-20T10:03:04Z” level=info msg="Metadata OnChange received, version: 810-4f3c5c96fb170da7fa8781d4ac55192c"
20/11/2017 11:03:04time=“2017-11-20T10:03:04Z” level=info msg=Reconfiguring

Has anyone got any idea how to get the Hosts connected?

Let me know if you need more Information

Sorry for the Noise. The Main Problem was, that the Hosts tried communicating via ipv6