How do I remove a storage pool?

So, I’ve been playing with Convoy-gluster and Convoy-NFS. As a result, I have four storage pools in the Rancher UI, even though there are no convoy stacks defined. How do I remove these? They seem to be causing issues elsewhere.

Also, even when I have a stack present, the ‘Add volume’ gives me a form which, when submitted, does absolutely nothing. This may be because of the multiple orphaned storage pools, but I cannot delete those…

Trying to disable the storage pools via the API also does nothing.

This is all running on Docker 1.9.1 and Rancher 0.50.2

I have the same problem here and didn’t found a solution yet…
Here’s the issue:

i add a convoy nfs and my nfs server dies , and i cant manage storage pools anymore

if i try click infraestruture > storage pool

so how i can remove a storage pool

Did you try to reload to get to the page?

I recently had this issue; and just found a way to remove the storage pool.

First I removed and purged the convoy service and glusterfs stack. After deleting from the stack view, Under Infrastructure -> Containers you can see the list of delete containers, purge them all.

then I went through each stack and removed the inactive storage. Under Infrastructure -> Hosts, click on the host name, then on the bottom of the page click on the storage tab, remove and purge inactive items.

After all of that, under Infrastructure -> Storage Pool the storage pool was still there. I notice here that if you click on the name of the storage pool you would get directed to a blank page, and the url would look something like this:


This may look different for you. Now, if you ever viewed the api for a host, the url would look like this:


So, I wondered, is there some hidden api for the storage pool? YES!


On this page, in the upper left are some options. First click deactivate. A dialog would appear, click Show request, then click Send Request. Now do the same thing for Remove and Purge.

the 1a5 and 1sp6 will be different for you. To view the api for a host, click the sandwich menu on a host and view in API should be an option. I am not sure if the removing storage step is necessary; but that is what I did.

good luck.


This worked for me, thanks for pointing me in the API direction. I think we are clearly missing a button in the UI.

1 Like

Great, Thankyou! :slight_smile:

This also worked for me. Additionally it has given me a quick intro to the power of the API.

1 Like