How to add private registry on HTTP - not HTTPS


I just started using Rancher to learn and try out. It seems to be a great tool.

I have a Docker Registry coupled with Portus as the source of the images that the internal team develops. I could use the docker compose file to add and launch a stack on Rancher once I added the registry as insecure in the /etc/docker/daemon.json file.

But, if I try to add the registry in Rancher through Infrastructure->Registries -> Add Registry, it fails. Can someone help me do this?

So you have Portus on HTTP (what port are you using?) and no authentication which you want to use in Rancher. What fails exactly? Can you show us errors/screenshots?

The registry is not on HTTPS, can be accessed using HTTP only. Port is 5000

In Docker InsecureRegistry stands for registry that doesn’t need SSL/TLS. My registry needs authentication and I am providing the credentials.

BTW, I could resolve it. The UI says to avoid providing the protocol (like “https://”) in the server details. However, I added the “http://” in front of the server details and it got added correctly. Yet to try it out, whether it works or not.