How to configure IPv6 for RancherOS/Rancher/Haproxy (even forwarding to IPv4 would work, anything)?

I’ve been having some issues with this, I have eth0 to bind eth0:6 to my IPv6 connection. Unfortunately I’ve had some weird side effects and haven’t been able to get my load balancer to listen on IPv6. I’ve looked all over and can’t find solid answers.

After updating to latest, I’ve had rancher listening on all IPs and once after fumbling around Rancher UI would come up on the IPv6 as well (but not a single container), no longer the case — nothing comes up with IPv6.

My setup: multiple IPv6’s, one IPv6. The haproxy UI settings point to various containers, IPv4 works as expected, the custom config additions are pretty basic:
frontend 80
mode http
redirect scheme https code 301 if !{ ssl_fc }

backend 443_my_stack_
mode http
http-response set-header Strict-Transport-Security "max-age=16000000; includeSubDomains; preload"
http-response set-header Content-Security-Policy "default-src ‘self’ wss://%[ssl_fc_sni]; script-src ‘self’ ‘unsafe-inline’; img-src ‘self’ data:; style-src ‘self’ ‘unsafe-inline’; font-src ‘self’; frame-src ‘none’; object-src ‘none’"
http-response set-header Referrer-Policy “strict-origin”

ssl-default-bind-options no-sslv3 no-tlsv11 no-tlsv10 force-tlsv12

ssl-default-server-options no-sslv3 no-tlsv11 no-tlsv10 force-tlsv12