How to create a scheduling node for multiple hosts but not all

Hello, I’m new to rancher, sorry if I’m asking you something trivial, but I can not get a pod to run only on some hosts.

For example, I have a master1 host (with etcd and controlpane), and the hosts worker1 and worker2 (as workers).

I have the following scenario:

master1 - etcd and controlpane
worker1 - worker
worker3 - worker

I would like to run apache pods on more than one host but not at all, for example, only on the worker1 and worker3 hosts.

In the configuration of hosts labels there is the label “”, so I used it in the deploy of the pod. But it does not work.

Here’s a print with everything settings. The “Deploy Workload” screen, the host labels settings screen, and the screen when I finish deploying.

Sorry for the image, but I can only post 1 imagen, so I compiled it.
Could someone help me, what am I doing wrong? Thank you very much.

You can achieve this by using a node selector.

For example, on the nodes you can put a label like: run-apache=true

Then for the pods, you add a node selector (under the node scheduling section in the UI).