How to enable cgroups swap space controller

Is there a way to enable cgroups swap space controller on
SUSE Linux Enterprise Server 11 Service Pack 2? If this
is possible could someone provide steps needed to do this?

I dug up Release Notes which state:

“Right now only the memory usage with respect to a cgroup can be controlled.
The swap space used by the tasks within a cgroup cannot be controlled.”

The above is followed by:
“…This feature can be exploited by passing the kernel boot parameter “swapaccount=1” and can be
disabled by passing “swapaccount=0”. If the feature is enabled, an interface by name “memory.memsw.limit_in_bytes”
will be present under the memory controller…”

I tried setting swapaccount=1 in sysctl but still dont see memory.memsw.limit_in_bytes getting created in my cgroups.

Thanks, Jerry C


It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

Be sure to read the forum FAQ about what to expect in the way of responses:

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team