HTTP Server Keep Alive not working?

Hello, does anyone know why HTTP keep-alive connections don’t seem to work with Rancher? Is this a Docker issue or a Rancher issue? No matter what docker image I use keep-alives won’t work.

Through a load balancer service, or directly to a service/container?

Its being routed through the load balancer

@Lovecannon Ranhcer default haproxy config has “httpclose” mode set. @vincent do you think we should make it keepalive by default if the majority of the use cases would require this value? Before custom haproxy config default settings feature is implemented (

@Lovecannon keep-alive by default behavior is going to be enabled in the next Rancher release. Here is the PR ref: