Ingress controller 500

I’ve been using rancher for a little while, and the ingress controller has been working just fine.

However suddenly my application has stopped working, meaning i got a 500 error when visiting the hostname in the browser.
I tried to debug this as much as possible, but simply couldn’t figure out, why my application shouldn’t be working.
Then I went to browse the node ip, and the mapped port for the container, and the application worked great.

I created a nginx application, just to see if that worked, but sadly no.
I have no clue as to why this is no longer working. I tried restarting the nodes, and even the etcd and Control Plane, to no use.
I simply don’t know what could have triggered this, and I don’t know how to debug it.

At one point I added the environment variable -e CATTLE_TLS_MIN_VERSION=1.0
As I needed the ingress to accept TLS 1 for legacy reasons. Unfortunately this did not have the desired effect, so I reverted it.

Any tips on how to debug the load balancer would be much appreciated :slight_smile:

Ingress controller troubleshooting steps are described at, the environment variable CATTLE_TLS_MIN_VERSION is for the connection to Rancher (Rancher UI/API) itself, not any ingresses in your cluster.

Hi, thanks for your reply.
I’m sorry, but I’m kinda new to this.

I figured out it was possible to see the status and logs if you viewed the system namespace.
Here I got an error that TLS 1.0 was not supported/known. After removing that entry in the configuration everything went back to normal.

I don’t know if the CATTLE_TLS_MIN_VERSION changed anything, but something did :stuck_out_tongue:
Everything is back to normal now though.