Install rancher 2.6.2 on kubernetes but not working

hi every one,

I’ve just finished installing the rancher to manage an existing cluster, and followed the guide in the quick start, i used the existing cluster option and followed by installing ingress-nginx and cert-manager, through to install rancher with the letsencrypt option, finished successfully, but the web ui is not accessible, I think maybe because the main service does not have an external ip as below:

kubectl get svc -n cattle-system
rancher ClusterIP 80/TCP,443/TCP 37m
rancher-webhook ClusterIP 443/TCP 31m
webhook-service ClusterIP 443/TCP 31m

is their a missed step needed to complete the setup, there is a loadbalancer created during the ingress setup, shouldn’t that be the ip address for the domain name.

thanks in advanced.

You specify a hostname to be use for Rancher UI and the install process will create an ingress resource for you with that hostname. You then need your DNS (or local computer hosts file) to point at your load balancer or one of the systems with an ingress controller with that hostname (for me by default it was listening on 80 & 443). Then you should be able to connect to that hostname.

Thanks for your reply, it is appropriated.
I already did the a record in the DNS server and check it in the dig web interface to confirm it mapped, but the ingress created is broken. The rancher service is working if I forwarded ports but using the domain is not working.
I tried and expose the service rancher, the web hi worked fine but there was a security issue with the cert, because it was using another IP address from the DNS setting so I used another browser than chrome to walk through that.
what I thinks is that the original ingress created first place need to be connected to the rancher service, that will fit the cert challenge and will solve it.
should it be rebuild the ingress or is there a walk around, I again appreciate your reply and support.

updating status, the web UI is working fine, it look like its needed a long time that’s it.