Installer boot failure on IBM POWER6

Hi all,
I apologize in advance if I make any mistakes but I am new to this platform. I would like to evaluate SuSe Linux Enterprise Server on my IBM POWER6 machine, namely 9407-M15. However, I cannot get the installer to boot. I have already reset everything to factory defaults via SMS and wiped the NVRAM, to no joy.
This is what happens after choosing “Installation” from GRUB
Loading kernel …
Loading initial ramdisk …
OF stdout device is: /vdevice/vty@30000000
Preparing to boot Linux version 4.12.14-94.41-default (geeko@buildhost) (gcc version 4.8.5 (SUSE Linux) ) #1 SMP Wed Oct 31 12:25:04 UTC 2018 (3090901)
Detected machine type: 0000000000000101
command line: BOOT_IMAGE=/boot/ppc64le/linux
Max number of cores passed to firmware: 1024 (NR_CPUS = 2048)
Calling ibm,client-architecture-support… done
memory layout at init:
memory_limit : 0000000000000000 (16 MB aligned)
alloc_bottom : 00000000051d0000
alloc_top : 0000000008000000
alloc_top_hi : 0000000008000000
rmo_top : 0000000008000000
ram_top : 0000000008000000
instantiating rtas at 0x0000000007570000… done
DEFAULT CATCH!, exception-handler=fff00700
After which I am kicked out to Open Firmware.
What am I doing wrong?
Thanks in advance,

Is POWER6 still supported?

Can you launch SMS in diagnostic mode and see if you can capture more info?
SLES v15 GA worked on POWER9

I think you need BigEndian version for it. You are trying install ppc64le on old hardware. Probably this could be solved by firmware upgrade, but you will not find new firmware for old hardware.