Issues when running Air Gap Install

I have followed the instructions here Air-Gap Install | K3s

I am running Rocky Linux 8

When I run INSTALL_K3S_SKIP_DOWNLOAD=true ./ I get the following message.

[INFO]  Skipping k3s download and verify
[INFO]  Skipping installation of SELinux RPM
[ERROR]  Failed to find the k3s-selinux policy, please install:
    dnf install -y container-selinux
    dnf install -y

There is no information in the instructions about installing anything else on the system.

I installed container-selinux and rebooted

When I try to install I get the following error

dnf install -y
Last metadata expiration check: 2:52:08 ago on Wed 17 May 2023 06:28:08 UTC.
Can not load RPM file: /var/cache/dnf/commandline-a76fe31ae310b0c7/packages/.
Could not open: /var/cache/dnf/commandline-a76fe31ae310b0c7/packages/
Cannot remove /var/cache/dnf/commandline-a76fe31ae310b0c7/packages/

I have tried running the same process on Ubuntu 22.04 and it works fine. Do we know if the Air Gap install process (The instructions) are compatible with RedHat based distributions?

Any help would be much appreciated.

@Simon_Carr Hi did you verify the k3s version and your Rocky Linux (8 dot ?) version are supported?