K3S No nodes found

Hi I have a RPi4 4GB with a clusterhat and 4 raspberry pi zero 1 (base model now wifi)
I was following network Chuck’s tutorial and I can get the Master online but it doesnt see the nodes.
I ran this on the nodes:

curl -sfL [https://get.k3s.io](https://get.k3s.io/) | K3S_TOKEN="I put my K3S Token Here" K3S_URL="https://[I Put My Server IP Here]:6443" K3S_NODE_NAME="I Put My node Hostname Here" sh -`

When I run this on the Master it doesnt see the nodes.

kubectl get nodes
NAME      STATUS   ROLES                  AGE   VERSION
cbridge   Ready    control-plane,master   20h   v1.23.6+k3s1

How to I fix this please?
I’ve restarted all of them but no success.

So after some extensive googling I found something on GitHub. It hasnt fixed the issue but its pointing me somehwere.
I ran:

sudo systemctl status kubelet

and received the following on all the nodes:

Unit kubelet.service could not be found.

If I have run the install command and received no errors on each node during install how can this not be there?
And how do I fix it?

I don’t use K3S, but RKE2 is the same base and I use that. What I have from the systemd stance is an rke2-server or an rke2-agent service. If I poke around using ps -ef | grep -i kubelet I find a running instance and when I check the parent PID I find that parent is rke2 server (I checked it on one of my server nodes). So I presume you have similar k3s-server or k3s-agent services and those should be in charge of keeping your kubelet running and you’d stop or restart them to get things back (I know with rke2 there’s an rke2-killall.sh script that’s needed to truly stop everything, so you might look for the K3S equivalent if a simple restart doesn’t help).

Thank you, yes there are k3s-server and k3s-agent and a k3s-killall.sh script too.
I am new to Kubernetes and am doing this as a learning tool.
I have a RPi4-4gb with this cluster hat https://clusterhat.com/ and 4 Pi Zero 1.3.
I can see all of them and they all have the shared key from the Pi4.
I can SSH into all of them but the server doesnt see the nodes and I dont know why or how to fix it.
There seems to be very limited resources online or my google fu is terrible.


are all I know to point to. As I said, I’ve never used K3S, but I used the equivalent RKE2 docs and they weren’t perfect and required some poking around and debugging, but part of that was because I was being weird and doing things like trying to leave SELinux enforcing.

Good luck.

Thank you very much.
I’ll take a look at those later.
Hopefully there is something there to help. :pray: