Kubectl exec - api timeout?

I have been using k3d, moving a small app from a vm to k3s. When I start a shell in the application pod using “kubectl exec -it podname – bash”, it times out after a certain amount of time if there is no activity and disconnects. One bash shell command I use doesn’t have output for a while so the connection times out consistently. I can start a background process that will output a space every 59 seconds, and that keeps the connection alive until my shell task is done. I have not figured out how to adjust this timeout. Is there a setting somewhere that I can change that I have not found yet?

1 Like