Kubelet pull timeout in Dockerized Rancher

Hi,

I’m having problems with a very big image which kubelet is unable to pull in 2 minutes, which is the default timeout.

I would like to increase the timeout for my cluster, which runs using the Rancher Docker container (rancher/rancher v. 2.4.13).

The kubelet option I would like to use is “runtime-request-timeout”, which has to be passed as a CLI parameter. Is there any way I can pass this option to the kubelet container when it starts?

Thank you.