Kubernetes Custom NodePort Range


I am trying to deploy a K8s cluster with a Custom NodePort Range and I am running into some issues.

First I forked the existing K8s template and modifying it by adding the “–service-node-port-range” option under “kubernetes.command.kube-apiserver” in the “docker-compose.yml.tpl” file. I put the fork into a custom catalog, then when I launch it I am getting a “Busy processing [SERVICE.##]” error.

Any help on how to accomplish implementing custom nodeport ranges would be greatly appreciated.


1 Like

anybody does not have any solution?