Links not working in a clean deployment


I just set up a new docker instance in a server. I’ve been playing locally in a ubuntu server in my house during the last month to learn how docker and Rancher works, so I have a whole working server working there.

However I launched it in an online server (just one VPS as the host) and for some reason containers can’t speak to each other. For example, if I deploy Wordpress, from the catalog, the website complains it can’t contact the database.

If I login inside the container and I try to check the ENV variables, they are there, but I can only connect to the other container via IP, if I use the other container name (as wordpress is using), this doesn’t work at all!

Any advise on this? It’s something related to the name resolution of the host, so, I’d say something related to the internal DNS of rancher or docker…

I’ve tried with the latest 5 versions 0.63.1, 1.0.0 (RC1) and others, but all with the same result…

Rancher version: from 0.63 to 1.0.0 RC
Docker: 1.9.1 or 1.10.3


@sturgelose do you mind sharing your application’s compose file? If the service is created via UI, you can generate it from there by Stack->View Config. We’ve added support for containers to be resolvable by name cross stacks with this PR:

and it should be available in RC 1.0.0. Would like to debug on application you are trying to deploy


Sorry for the issue. Seems there was some kind of problem with the Kernel modules, as OVH had a custom kernel.

It was discussed somwhere in the github issues, but it would be good to write down all this requeriements more visible.

In case someone else is looking for it, but this is the issue.