Load Balancer Request Path not working

Hi there,

running Rancher v 1.1.1 on 4 Hosts (1 Rancher + 3 Servers to run the containers on).
I have a couple of services running and its all great :slight_smile:

I am also running Drone and I was trying to get Drone/Wall to run as well.
So I created a new service inside the Drone Stack.

So my Drone stack looks like this:

  • Drone-Server + 3 Sidekicks = running on Port 8000
  • Drone-Wall = running on Port 80

Now I added a load balancer listening on port 80.
Inside the targets I specified the following:

Now when I browse to drone.domain.com I see the Drone CI. But when I browse to drone.domain.com/wall I see a 404 page (probably coming from Drone Server).

Did I miss anything?



I’m not familiar with drone wall, but the matching portion of the path is not removed from the request that is sent to the target services. So the request is probably going to the wall container, but it responds with 494 when asked for /wall.

Some applications have an option to configue the base URL they are being served out of. Otherwise you’ll have to use host-based-routing. The balancer removing the path from the request to the target would work too load the HTML, but then break any absolute or root-relative links/js/css/images/etc that the application tries to reference.

Hi Vincent. This totally makes sense and I wasn’t aware of it. Will see on how to change the configuration of the container to use a different base URL.