Modify the default version of openssl ?

On SLES12 SP5, default version of openssl is 1.0.2, and 1.1.1 is optional. Is it possible to modify the default version on 1.1.1 ? (and still have official support…)

@Frederic Hi, what makes you think it’s not supported?

I see it coming from the update repository?


1.1.1 is brought from the update repository, no issue on it but I wonder if we could have only this version installed, no 1.0.

@Frederic Hi, have you tried uninstalling the older versions? (I don’t have 12 SP5 machine to check).

Yes, I tried a zypper rm openssl-1_0_0 or openssl and it asks to uninstall 80+ libraries (with zypper, yast2, etc…) :

@Frederic Hi You need to look at the specific versions to uninstall… eg 1.0.2p-1.13
Use zypper se -si openssl

Hi !
zypper se -si gives me the installed package but how to remove a specific version such as openssl 1.0.2p ? (zypper rm openssl gives me same result as for openssl-1_0_0)

@Frederic Hi, should be the name, version and the arch from the -si output, for example;

zypper rm openssl-1.0.2p-1.13.x86_64

it doesn’t work… or rather it works like the previous one : it asks to uninstall the same 83 packages.

@Frederic It’s a noarch not a x86_64, but there shouldn’t be any issues, CVE’s are backported, so you can always check the changelogs or SSC → My Tools for more information.

@Frederic: Did you get this resolved, I have same issue trying to change it to default version. Its not happening. Just curious to understand if you had any solution.?

@Ramakrishna unfortunately not :frowning: