New Rancher install - unable to connect

Hi Everyone,

I am trying to set up my first Rancher install.

After running the “docker run” command (see below) I can use “docker ps” to see that rancher is running.

However, when I try to connect to the rancher website, I get a default “unable to connect” message.

I thought it might be firewall related but I ran “ufw status verbose” and see that the firewall is disabled.

Not sure how to start troubleshooting this issue.

Host: Windows 10
Virtualization: VMware Workstation 15.5.2
VM OS: Ubuntu 20.04
Docker Version: 20.10.6
Rancher Install Command: sudo docker run -d --restart=unless-stopped -p 8080:80 -p 8443:443 rancher/rancher

What URL are you trying to access? What network interfaces do you have configured for the VM and what type of network is configured? Easiest way to rule out a network problem is to access the service locally to see if it responds.

Superseb, thanks for the reply.

I have a simple network environment, each of my 4 VM’s only have a single network interface (not counting the Docker interface) and all are using NAT in VMware Workstation.

I have tried to access the environment from both the Windows 10 host as well as the Linux VM running Rancher. I have tried both http://:8080 and https://:8443.

By accessing the service locally, do you mean trying to access the URL via the Linux VM or are you referring to logging into the Docker container running Rancher using “docker exec -it …” or something else?

Thank you again for your reply. I appreciate the help.


I looked at the docker logs for the container and the issue was clearly being displayed.

I am trying to run rancher outside of Kubernetes. I was getting the following error:

ERROR: Rancher must be ran with the --privileged flag when running outside of Kubernetes

Once I added the --privileged flag everything started working properly.