Nginx-ingress-controller set large_client_header_buffers

anyone who can help me with setting the large_client_header_buffers-parameter to the NGINX-Config of nginx-ingress-controller inside ingress-nginx namespace?
I already tried with annotations and data in the ConfigMap nginx-configuration, but it is not applied.
The config itself seems to be reloaded, but the parameter is not updated.

I used this documentation:

My ConfigMap looks like this:

apiVersion: v1
kind: ConfigMap
  large_client_header_buffers: "4 128k"
  annotations: |
  creationTimestamp: 2018-05-04T11:48:09Z
app: ingress-nginx
  name: nginx-configuration
  namespace: ingress-nginx
  resourceVersion: "24674828"
  selfLink: /api/v1/namespaces/ingress-nginx/configmaps/nginx-configuration
  uid: 04695351-4f91-11e8-8a97-005056874968

When I check the nginx-ingress-controller-Pod-Logs it says:
2018-07-17T09:52:55.758465395Z I0717 09:52:55.758221 8 controller.go:171] backend reload required
2018-07-17T09:52:55.90571432Z I0717 09:52:55.905461 8 controller.go:180] ingress backend successfully reloaded…

And a check of the config inside one of those Pods shows, the large_client_header_buffers-Parameter is still at the default value:
~# kubectl exec -n ingress-nginx -it nginx-ingress-controller-542q2 – cat /etc/nginx/nginx.conf | grep large_client
large_client_header_buffers 4 8k;

I also tried with annotations directly one one of those Pods and in the ConfigMap, but I don’t get large_client_header_buffers-Parameter updated.

Can anyone help please?


Good luck with this, we are still seeing the issue where we setup a config map at the System level for the ingress controller workload, reload all the pods, and nginx.conf still doesnt get updated. I’ve read that people have recreated their clusters and then all of the sudden it starts working. Im still digging.

Good luck.

Could you try using kebap case instead of snake case


A list of possible config map options may be found here: