NVIDIA Drivers with SUSE RT Server

Hi All,
I have a desktop on which I have installed SUSE Linux Enterprise Server 11 SP2 and the Real Time extension.
I have a graphics card NVIDIA GeForce 7600GT.
The problem is that I can’t get the NVIDIA drivers to work:
When I installed the NVIDIA drivers (304.88), either by package manager or manually, it worked very well on the ‘regular’ kernel, but when I switched to the RT kernel, I couldn’t start the X server and run the desktop:
I got the following error:
suse warning gdmlocaldisplayfactory maximum number of x display failures reached
And when I read the X logs I got the error:
No screens detected
The main reason that I need the NVIDIA drivers is to work with dual display, so I don’t care if I install another drivers which are not propriety, but I couldn’t find any,
Can anyone tell how can I find correct drivers to work with the RT kernel?
Maybe I need an older version of NVIDIA?


Did you start the system (or change to) runlevel 3, the re-run the
configuration tool?

sax2 -r -m 0=nvidia

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.16-desktop
up 5:50, 3 users, load average: 0.44, 0.23, 0.17
CPU AMD E2-1800@1.70GHz | GPU Radeon HD 7340

Yes. I have also tried this.
I got an error message that referred me to /var/log/SaX.log
There it was written:
Fatal server error
no screens found