Openstack config seems to be missing? Can't add a host to Openstack

In the latest Rancher release, the option for adding an openstack host seems to be missing.

From the UI, when I select openstack driver, no fields are shown.
From the API create action page, when I click openstackconfig I get;
“id”: “eabed400-4624-4d38-a654-33f29436e4cd”,
“type”: “error”,
“links”: { },
“actions”: { },
“status”: 404,
“code”: “Not Found”,
“message”: “Not Found”,
“detail”: null,

There is a bug in the current release where you can’t get machine driver schemas individually by ID… If you list /v1/schemas (or /v1/projects/<projectId>/schemas) it should be in the list.

@ebishop Could you open an issue in Github for it? I don’t believe there is one for this right now.

Can’t enter Openstack config data when adding a host. #4719

Vincent, maybe I don’t understand what you mean, or something more is broken. Following your advice, I navigated to the schema link, and searched for opensstack. I found three chunks of information but they look sort of empty.

I’m using Chrome, and I tried Firefox also after clearing all rancher related cookies just in case, but no change. I can’t add a host in Openstack.

The first one is the openstackConfig field for the machine resource, and looks normal. The 2nd one is the actual openstackConfig schema itself, and should have a bunch of resourceFields. that appear to be missing. Try restarting the rancher/server container, there are a few bugs that were introduced with dynamic drivers and one of them was that the driver configs could get saved with the wrong/no fields, but restarting the server should fix it.

:slight_smile: That did it.

looks like Openstack config is missing again. I tried restarting rancher server and it’s still not there.

I recently upgraded to v1.1.0-dev3

This time when I navidate to /schemas, there is no mention of openstack.

Please, advise.

I upgraded to v1.1.0-dev4, started the Openstack machine driver, and everything is working again. I suppose I caught you in a transition. :grin:

This issue still persists even after I upgraded to 1.1.2, that
/v1/schemas/genericConfig gives me nothing.

I just want to add generic host. If UI doesn’t work, can I do it programatically? I’m working on auto scaling rancher clusters on my private cloud, btw.