Pacemaker DRDB

my environment is:

I added to my admin node 1 new disk with 10GB, i formatted as ext4 and created a lvm mounted in /cloud , in this directory i create a sbd.img using “dd” and shared this .img file using iscsi to my 2 control nodes.
In my two control nodes i enable the softdog module and installed the sbd package using “zypper in sbd” and executed sbd -d /dev/disk/by-path/ip… create, and after sbd -d /dev/disk/by-path/ip… dump , this two commands don’t returns any error, but when i try use the “list” option don’t return my nodes information.
I tried create the pacemaker cluster using the crowbar interface but returns me the followed error There is no suitable disk for LVM for DRBD

i havent use sbd fencing mech so far, but i am familiar with drbd,
can you please post your drbd config used?

also what cat /proc/drbd shows?


You need at least one unused disk on each member of the cluster where you want DRBD. It seems this is not the case, and that’s what the error is saying. (You’re mentioning sbd, but that bit seems to have gone well)